Sep 16

Distribution Madness

Over the past 48hours I've gone through 3 different installations of distributions. I've started with an Ubuntu 64bit. Sadly the jaunty jackalope has only really old stuff in it. Mainly the old subversion version was a no go, as I need to work on my diploma thesis which I manage in a SVN-repository. The svn from jaunty told me it was too old. After an upgrade of the whole system to karmic (dev version I know... it's all my own fault now) just to get to a state where I can actually work with my system it worked for a while. Yesterday the update-manager bugged me again, wanted to do some 300 packages again. Fine with me. BUT after that the kernel wouldn't start no more. It seemed the splash screen was broken. After removing the relevant part from the grub config I could boot. Without the nice splashscreen... but whatever. After unlocking my encrypted discs everything was fine. At least it seemed that way. I could login, so far so good, but as soon as I tried to start a terminal -> could not start child process... in addition to that the network didn't work. Great. *annoyed*

Next step: Linux Mint. Mint is a derivate of Ubuntu and has some nice guitools to administrate your box. So I installed the x64 version. Looks nicer than ubuntu (imho). But still old software. (Firefox 3.0 ?!?!). After updating and googling for the dev release. Helena and karmic back in the sources.list. Some 1000 packages later, the update fails at xserver-xorg. Ah well. No worries, it's the dev-version so who am I to complain.

Tried to get some work done: installed GWT as eclipse plugin. Oh wonder what, it doesn't work with native 64bit java. So far I didn't have an problems with eclipse and 64bit java for some time. Ok, after installing and setting up a 32bit jvm for this project, GWT seemed to work. Beside the integrated browser (mozilla). That one needed some old libs (libstdc++5) which, of course, aren't available anymore in karmic/helena....

Ok, start over. Next try 32bit Mint 7. Additionally to upgrading to helena/karmic straight, I had to use the linux-server kernel, or otherwise I could only use 3.3 GB of my 8Gigs of ram :/ ..
So now I'm sitting here with a 32Bit Mint7. So far so good. Nearly everything works (the volume/track controls on my keyboard are broken again, those worked in ubuntu flawlessly)
Just the updates are failing again everywhere:
Errors were encountered while processing:
acpid
acpi-support
gnome-system-tools
xserver-xorg
inxi

Oh my. I just hope some day, one can have a current linux installation that simply works and has packages which are not from the stone age...
I just wonder how a user who just switched from MacOSX or Windows to linux should cope with such problems ...

Seems I'm going back to Gentoo. I'll have to do much more by myself, but at least it works then...

Share

Sep 13

Phoronix Test Suite on Ubuntu

After installing the Phoronix Test Suite on Ubuntu (9.10 Karmic Koala on AMD64) I tried to start the GUI.
Unfortunately there was an error:
kazamatzuri@maya:~$ phoronix-test-suite gui

The PHP GTK module must be loaded for the GUI.
This module can be found @ http://gtk.php.net/

After googling a bit, I found the fastes solution to be:

  1. Get the php-gtk package: http://www.phoronix-test-suite.com/misc/php5-gtk2_2.0.1-0_amd64.deb
  2. install it with sudo dpkg -i php5-gtk2_2.0.1-0_amd64.deb
  3. get your php to load the extension: sudo echo "extension=php_gtk2.so" > /etc/php5/conf.d/gtk.ini

There you go, now it works (at least for me;))

Share